Interlochen Center for the Arts

Campus Technology Services

Fine Arts building network outage

minor icon Minor
Campus Internet and Phone Services icon
Campus Internet and Phone Services
Identified icon Identified

Incident timeline

minor icon Minor

Identified - Fiberoptic connection to Fine Arts was damaged during an underground dig event between Admisson and Fine Arts.

Affected:
Campus Internet and Phone Services icon
Campus Internet and Phone Services